[p4perl] Linux build problems

Roger Day roger.day at globalgraphics.com
Tue Feb 22 04:48:01 PST 2005


I found the problem. We have two gcc's installed on our machines - gcc 
2.95.2 and the distributed compiler, 3.2. Switching the compiler to gcc 
3.2 - the correct one for Red Hat 9 - makes the client tests run in  grand 
fashion. 

BTW, setting CC didn't seem to make a difference  - running perl 
Makefile.PL gives you - amongst other things - "Warning: CC is not a known 
parameter".

Has the client been ported to RHEL and macos X 10.3?

Cheers,

Roger

P.S sorry about the earlier double emails but I've problems with a VPN 
connection and Lotus Notes. Ugh!





Tony Smith <tony at smee.org>
Sent by: p4perl-bounces at perforce.com
21/02/2005 17:26
 
        To:     p4perl at perforce.com
        cc: 
        Subject:        Re: [p4perl] Linux build problems


Roger,

Did you get past this? I can see later messages from you which imply 
you've
got it working?

If not, then please send me the output of

perl -V
gcc -v

on your machine so I can check the build environment.

Thanks,

Tony

On Monday 21 February 2005 11:40, Roger Day wrote:
> I get this problem for RedHat 9.0, using both the 2.6 and 9.0 libraries.
> Has anyone else seen this? Is there a workaround? can I complile the
> sources mself?
>
> Roger
>
> -bash-2.05b$ make test
> cp P4.pm blib/lib/P4.pm
> AutoSplitting blib/lib/P4.pm (blib/lib/auto/P4)
> cp example.pl blib/lib/example.pl
> PERL_DL_NONLAZY=1 /usr/bin/perl "-Iblib/lib" "-Iblib/arch" test.pl
> 1..5
> Can't load
> 
'/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/P4/Client/Clie
>nt.so' for module P4::Client:
> 
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/auto/P4/Client/Clien
>t.so: undefined symbol: Message__10ClientUserP5Error at
> /usr/lib/perl5/5.8.0/i386-linux-thread-multi/DynaLoader.pm line 229.
>  at blib/lib/P4.pm line 183
> Compilation failed in require at blib/lib/P4.pm line 183.
> BEGIN failed--compilation aborted at blib/lib/P4.pm line 183.
> Compilation failed in require at test.pl line 11.
> BEGIN failed--compilation aborted at test.pl line 11.
> not ok 1
> make: *** [test_dynamic] Error 255
> I
>
>
> _______________________________________________
> p4perl mailing list
> p4perl at perforce.com
> http://maillist.perforce.com/mailman/listinfo/p4perl
>
> !DSPAM:4219c8d2220638793535952!
_______________________________________________
p4perl mailing list
p4perl at perforce.com
http://maillist.perforce.com/mailman/listinfo/p4perl

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.perforce.com/pipermail/p4perl/attachments/20050222/c0baa5e0/attachment-0001.html>


More information about the p4perl mailing list