[p4perl] Problem Running P4Perl Based Triggers After Linux SystemUpdate

Tony Smith tony at smee.org
Thu May 8 06:18:19 PDT 2008


Scott,

> We are using 2007.2, and have been since it came out. The only thing
> that changed in this system was the Linux updates. I have not upgraded
> to 2007.3 yet. I was planning to do so in the next month or so.
>
> The weird thing is that I can do any Perforce command successfully from
> the command line or 'p4v' on this machine. It's just when I use P4Perl
> that I have these issues. Is there something in the Linux patches that
> could be causing this problem? I have recreated the ticket already,
> after this problem started.

The issue is that you're using P4Perl built with the 2005.2 API. So it's 
effectively a 2005.2 client. The 2007.2 P4 you're using stores tickets in the 
tickets file differently, so if you run a 'p4 login' using your 2007.2 P4, 
the 2005.2 P4Perl won't find the ticket and will give you a P4PASSWD error.

There are really three solutions:

1. Upgrade your P4Perl to the official 2007.3 release from Perforce, and build 
with the 2007.3 API

2. Upgrade your P4Perl to the latest Public Depot P4Perl build (3.6001), and 
build it with the 2007.2 API

3. Run a 'p4 login' from within a P4Perl script to get a ticket stored in the 
way P4Perl expects it to be stored.

I'd suggest #1 is better as Public Depot P4Perl is deprecated in favour of 
Perforce P4Perl.

Regards,

Tony



More information about the p4perl mailing list