[p4perl] P4Perl help (make test => some tests fail)

Billy Suh billy.suh at oracle.com
Fri Nov 18 09:13:18 PST 2011


Thank you Tony. After doing what you said the tests passed!

Thank you again!

 

From: Tony Smith [mailto:tony at smee.org] 
Sent: Tuesday, November 15, 2011 10:23 AM
To: HYPERLINK "mailto:p4perl at perforce.com"p4perl at perforce.com
Subject: Re: [p4perl] P4Perl help (make test => some tests fail)

 

Hi Billy,

On 10/11/2011 22:50, Billy Suh wrote: 

I happen to be using a two-person version of an old p4/p4d on linux (P4D/LINUX22X86/2004.2/69887 (2004/10/14)) as part of my proof-of-concept,! because I do not want to run the tests against the production p4d server.(Would it be safe to run the tests against the production server to see if the tests pass?) 

 

Tests and production servers definitely do not mix! 

However, the fact you're using a 2004.2 server is probably what's choking the tests. The tests are carried out in a server started in a subdirectory of the p4perl build environment; all they need is a 'p4d' in the PATH. If you ensure that the p4d binary in the PATH is a 2011.1 (or 2010.2) server, do the tests pass then?

For example:

$ mkdir p4tmp
$ cd p4tmp
$ wget http://www.perforce.com/downloads/perforce/r11.1/bin.linux26x86/p4d
$ chmod 755 p4d
$ export PATH=`pwd`:$PATH

Then go to your p4perl build directory and run 'make test'. If it all works, you can remove the p4tmp directory.

Tony
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.perforce.com/pipermail/p4perl/attachments/20111118/b229fa9a/attachment-0002.html>


More information about the p4perl mailing list