[p4python] AttributeError: 'module' object has no attribute 'P4'

Robert Cowham robert at vaccaperna.co.uk
Mon Jun 26 04:54:05 PDT 2006


Strange.
 
What version of Python did you install? Activestate?
 
Check your python path too:
 
python
>>> import sys
>>> print sys.path
 
Check for anything strange there.
 
Robert
 


  _____  

From: p4python-bounces at perforce.com [mailto:p4python-bounces at perforce.com]
On Behalf Of Guillaume Boddaert
Sent: 26 June 2006 12:27
To: p4python at perforce.com
Subject: Re: [p4python] AttributeError: 'module' object has no attribute
'P4'


Hi Robert, thanks for you answers.

I removed and reinstalled python, and p4extension. I also checked the
Site-packages dir :

c:\> dir c:\Python24\Lib\site-packages
 Volume in drive C has no label.
 Volume Serial Number is XXXX-XXXX

 Directory of c:\Python24\Lib\site-packages

26/06/2006  13:10    <DIR>          .
26/06/2006  13:10    <DIR>          ..
22/07/2005  05:24            11 100 p4.py
26/06/2006  13:10            12 010 p4.pyc
26/06/2006  13:10            12 010 p4.pyo
31/08/2005  14:28           352 256 P4Client.pyd
28/10/2005  20:15               121 README.txt
               5 File(s)        387 497 bytes
               2 Dir(s)  235 439 333 376 bytes free

I also reduce my test script to a simple : "import p4"

Traceback (most recent call last):
  File "C:\workspace\HelloPython\p4test.py", line 35, in ?
    import p4       # Main class to test
  File "C:\Python24\Lib\site-packages\p4.py", line 3, in ?
    """A Python version of the Perforce "p4" client.
AttributeError: 'module' object has no attribute 'P4'

I didn't import any other P4 feature for python.

Guillaume


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.perforce.com/pipermail/p4python/attachments/20060626/ab581e53/attachment-0001.html>


More information about the p4python mailing list