[p4python] P4Python script called from P4V sets P4CHARSET

Jan Van Uytven juytven at perforce.com
Fri Feb 27 11:10:09 PST 2009


Hi P4Python folks,

I've come across a bit of weirdness with P4Python.

I've written a P4Python script that's designed to be called from P4V.  
This is on Windows, with a 2008.2 server and P4V.  Python is 2.5.

p4 set doesn't show P4CHARSET being set.
The server is not unicode-enabled.
P4V hasn't been started with P4CHARSET set.

I ran the script on the command line and it worked as expected, so I set 
it up in P4V's custom tools menu, setting it to run in a terminal window 
for debugging purposes.  I run the tool and get the message:

"unicode enabled clients require a unicode enabled server"

Curious, I do a dump of p4.charset and get 'utf8' when the script is run 
from P4V.  Why is this?  How do I unset it?  I tried p4.charset = "" but 
that resulted in an error.

Cheers,

Jan

-- 
Jan Van Uytven
Perforce Support Engineer

"If knowledge can create problems, it is not through 
ignorance that we can solve them." - Asimov 




More information about the p4python mailing list