[p4ruby] Compilation errors with latest stable + 2006.2 API

Tony Smith tony at smee.org
Thu May 17 08:27:15 PDT 2007


Hi Johan,

> I'm getting a couple of compilation errors when trying to compile the
> latest stable P4Ruby together with the 2006.2 API.
>
> Lots of warnings from non-matching signatures from Spec declarations
> (they were missing a Error* argument). FWIW, adding the Error* arguments
> "cures" the problem, i.e. makes it at least pass compilation.

Use the development build of P4Ruby. 2006.2 wasn't out when the stable build 
was released.

Tony



More information about the p4ruby mailing list