[p4ruby] p4ruby problem acc. to integrate

mkellner at nemetschek.de mkellner at nemetschek.de
Mon Oct 8 09:51:58 PDT 2007


Hi Tony,

Server address: p4server.entw.nemetschek.de:1667
Server root: E:\P4Improve
Server date: 2007/10/08 18:34:47 +0200 W. Europe Daylight Time
Server version: P4D/NTX86/2007.2/133058 (2007/08/30)
Proxy version: P4P/NTX86/2007.2/122958 (2007/05/22)

Regards,
        Martin Kellner


                                                      Configuration Manager
                                                      Team CAD Organisation
                                                ("NE KE_Team_Organisation")

                                               Tel.:   +49-(0)89-92793-1561
                                                Fax:   +49-(0)89-92793-4561
                                            Email:   mkellner at nemetschek.de

                                                 Nemetschek Technology GmbH
                                                        Konrad-Zuse-Platz 1
                                                          D - 81829 München

                                                           Geschäftsführer:
                                                              Ernst Homolka

                                                               Sitz München
                                             Amtsgericht München HRB 147169




Tony Smith <tony at smee.org> schrieb am 08.10.2007 18:03:48:

> Hi Martin,
>
> P4Ruby just gives you the output sent by  the server, so I suspect that
the
> issue here is that your old, and new environments are using different
> versions of the Perforce server.
>
> Could you check that, and let me know if that's the case?
>
> Thanks,
>
> Tony
>
> On Monday 08 October 2007 14:17:51 you wrote:
> > Hi together,
> >
> > due to the fact that we did upgrade our Perforce server up to 2007.2
/133058
> > I do test now the newer P4Ruby interface:
> >
> > I have problems according to the integrate command and a moved file.
The
> > corresponding branch spec contains a corresponding line:
> > p4 branch 2005_LATEST_to_MAIN:
> >
> >
//Allplan/Products/2005/LATEST/Libs_Allplan/Libs_Fertigteile/fertallg/sqatt
> >r.cpp
> >
> >
//Allplan/Products/MAIN/NemAll_Data/NemAll_DataFertigteil/FertSource/sqattr
> >.cpp
> >
> > The revision graph looks like this:
> > (See attached file: revisiongraph.gif)
> >
> >
> > On my old machine still having the old toolset everything is ok, which
> > means //.../2005/...#2 has to be integrated:
> > P4 Client 2006.1/113344, Ruby 185-21, P4Ruby 1.4841-1.8.0
> >
> > p4 integrate -i -b 2005_LATEST_to_MAIN -n //Allplan/...
> > ...
> >
//Allplan/Products/MAIN/NemAll_Data/NemAll_DataFertigteil/FertSource/sqattr
> >.cpp#3 - integrate from
> >
//Allplan/Products/2005/LATEST/Libs_Allplan/Libs_Fertigteile/fertallg/sqatt
> >r.cpp#2 ...
> >
> > ruby Test_Integrate.rb
> > ...
> >
//Allplan/Products/MAIN/NemAll_Data/NemAll_DataFertigteil/FertSource/sqattr
> >.cpp#3 - integrate from
> >
//Allplan/Products/2005/LATEST/Libs_Allplan/Libs_Fertigteile/fertallg/sqatt
> >r.cpp#2 ...
> >
> >
> > On my new machine having the new toolset the wrong revision is detected
if
> > p4ruby is used, which means //.../2005/...#1 should be integrated (p4
> > command line still is ok):
> > P4 Client 2007.2/133058, Ruby 185-21, P4Ruby 1.5953-1.8.2
> >
> > p4 integrate -i -b 2005_LATEST_to_MAIN -n //Allplan/...
> > ...
> >
//Allplan/Products/MAIN/NemAll_Data/NemAll_DataFertigteil/FertSource/sqattr
> >.cpp#3 - sync/integrate from
> >
//Allplan/Products/2005/LATEST/Libs_Allplan/Libs_Fertigteile/fertallg/sqatt
> >r.cpp#2 ...
> >
> > ruby  Test_Integrate.rb
> > ...
> >
//Allplan/Products/MAIN/NemAll_Data/NemAll_DataFertigteil/FertSource/sqattr
> >.cpp#3 - integrate/sync -
> >
//Allplan/Products/2005/LATEST/Libs_Allplan/Libs_Fertigteile/fertallg/sqatt
> >r.cpp#1 ...
> >
> >
> > The small ruby script is:
> > (See attached file: Test_Integrate.rb)
> >
> >
> > Have I a bug inside the script? Or is there running something wrong
inside
> > p4ruby according to such a moved file? How can I solve the situation?
> >
> > Thanks in advance.
> >
> > Regards,
> >         Martin Kellner
> >
> >
> >                                                       Configuration
Manager
> >                                                       Team CAD
Organisation
> >                                                 ("NE
KE_Team_Organisation")
> >
> >                                                Tel.:
+49-(0)89-92793-1561
> >                                                 Fax:
+49-(0)89-92793-4561
> >                                             Email:
mkellner at nemetschek.de
> >
> >                                                  Nemetschek Technology
GmbH
> >
Konrad-Zuse-Platz 1
> >                                                           D - 81829
München
> >
> >
Geschäftsführer:
> >                                                               Ernst
Homolka
> >
> >                                                                Sitz
München
> >                                              Amtsgericht München HRB
147169
> >
> >
> >
> >
> >
> > **********************************************************************
> > This email and any files transmitted with it are confidential and
> > intended solely for the use of the individual or entity to whom they
> > are addressed. If you have received this email in error please notify
> > the system manager.
> >
> > This footnote also confirms that this email message has been
> > inspected by an antivirus software.
> > **********************************************************************
> >
> >
> >
> > !DSPAM:470a427f253531040847652!
>
>
>
>
>
--------------------------------------------------------------------------------

> This email and any files transmitted with it are confidential and
intended
> solely for the use of the individual or entity to whom they are
addressed. If
> you have received this email in error please notify the system
> manager. Please
> note that any views or opinions presented in this email are solely
> those of the
> author and do not necessarily represent those of Perforce Software.
Finally,
> the recipient should check this email and any attachments for the
presence of
> viruses. Perforce Software accepts no liability for any damage caused by
any
> virus transmitted by this email.
>
> Perforce Software UK Ltd is registered in England and Wales as company
no.
> 3816019 at the following address: West Forest Gate, Wellington
Road,Wokingham,
> RG40 2AQ, UK
>
--------------------------------------------------------------------------------


> ForwardSourceID:NT0025902E




More information about the p4ruby mailing list