[p4ruby] on ruby-1.9.x

Andy Koch andy.koch at pc-doctor.com
Tue Jan 10 12:00:32 PST 2012


Hi All, 

Anybody up for a p4ruby on 1.9 discussion?

I've been working to get p4ruby on 1.9.3p0, with the 11.1 p4 api this appears to install fine when doing the manual install.  No patch needed.

However, 'gem install p4ruby' appears to hang.

Any ideas?

I'll be poking at this today.  Ideally p4ruby should just be in a a Gemfile for some project and install via bundler.

But at least a manual install works.  So this is really a discussion on the gem install issue (aka convenience issue).


On Aug 12, 2011, at 3:23 PM, Vincent Batts wrote:

> All,
> 
> Attached is patch to get the r10.2 p4ruby to compile on ruby 1.9
> This was tested on ruby 1.9.1-p431 and 1.9.3-preview1
> 
> Take care,
> vb
> http://hashbangbash.com/
> <ruby19.patch>_______________________________________________
> p4ruby mailing list
> p4ruby at perforce.com
> http://maillist.perforce.com/mailman/listinfo/p4ruby

Andy Koch, Web Applications Developer
PC-Doctor, Inc.
10345 Professional Circle, Suite 183
Reno, NV 89521
775-336-4079
andy.koch at pc-doctor.com

CONFIDENTIALITY
The information contained in this message is confidential. It is intended to be read only by the individual or entity to whom it is addressed or by an authorized designee. If the reader of this message is not the intended recipient, be aware that distribution of  his message in any form is strictly prohibited. If you have received this message in error, please immediately notify the sender and  destroy any copy of this message.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.perforce.com/pipermail/p4ruby/attachments/20120110/2ed676d8/attachment-0002.html>


More information about the p4ruby mailing list