[p4] Resolve Bug?

Rich Ireland rireland at enterasys.com
Fri Dec 7 10:00:18 PST 2001


I've encountered something that I can only describe as a bug in resolve.

I have a open source code base that I'm following with a 'vendor' 
branch.  Every time it releases, I check the new source into this branch 
and then merge it into my ongoing development branch with a spec that 
looks like this:  \\depot\vendor\x\... \\project\y\...

Well, last night there was a new release and I was going through the 
almost automatic merge process - when I ran into a file that merged 
incorrectly.  I ran a build to check the merge and found that one (maybe 
more?) file that still had code in it that should have been removed by 
the incomming changes.  There were no conflicting changes, so it 
*should* have 'just worked' - but no.

Has anyone seen this before?  Should I stop using p4 resolve in auto mode?

-- 
Rich Ireland
Firmware Engineer
Enterasys Networks
mailto:rireland at enterasys.com




More information about the perforce-user mailing list