[p4] CVS to P4 Conversion - Label Problem

Peter Stephenson pws at csr.com
Fri Mar 4 09:59:58 PST 2005


"Venters, Cheryl" wrote:
> I'm converting many CVS repositories to P4 and am having trouble with the
> labels. In one of my imports, the files that are in a label do not even
> slightly match the files that are in that same label in CVS. Has anyone else
> had this problem and how did you fix it?

Yes, our problem was with branches; the models in CVS and Perforce are
so different that the conversion script has problems.  Therefore you
end up with labels on huge numbers of branches unnecessarily.  If
you're getting files with the label that are unrelated even by a branch,
it's a different problem.

What I did was hack the script to force the label only to take place on
a likely looking branch.  We force certain files (with version numbers)
onto the main line to ensure consistent numbering, so I had to add
a fix-up for files which were mostly in one branch but with a few files
on the main line.

I can dig the hacked version of the script out if you're interested.

-- 
Peter Stephenson <pws at csr.com>                  Software Engineer
CSR PLC, Churchill House, Cambridge Business Park, Cowley Road
Cambridge, CB4 0WZ, UK                          Tel: +44 (0)1223 692070


**********************************************************************
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they
are addressed. If you have received this email in error please notify
the system manager.

**********************************************************************




More information about the perforce-user mailing list