[p4] Verify -v not -v'ing...

Joseph Cochran g.jsciv at gmail.com
Mon Oct 3 10:00:47 PDT 2005


Thanks for the pointer. Looks like the zip program I used lied when it said
it was gzipping the stub file. From your message, I took the idea to try
another compression program, which worked. So problem solved

-- Joe

On 10/1/05, Robert Cowham <robert at vaccaperna.co.uk> wrote:
>
> Sounds like you haven't replaced the stub file correctly, since MISSING
> means it can't find it. Are you absolutely sure you have??
>
>  ------------------------------
> *From:* perforce-user-bounces at perforce.com [mailto:
> perforce-user-bounces at perforce.com] *On Behalf Of *Joseph Cochran
> *Sent:* 30 September 2005 16:50
> *To:* Jeff Jensen
> *Cc:* perforce-user at perforce.com
> *Subject:* Re: [p4] Verify -v not -v'ing...
>
> I'm using the method suggested by Richard Baum in his presentation at
> Perforce 2005:
>
> http://www.perforce.com/perforce/conf2005/presentations/BaumPaper.pdf
>
> I have replaced the archive file revision (//depot/firstbin.exe#1,1) with
> a stub file as explained in the paper, and am running "p4 verify -v
> //depot/firstbin.exe#1,1" on the file. According to the paper, and to the
> perforce documentation, this should re-generate the MD5 signature, however
> all I get is MISSING! when I run it. Again, since I don't get that error if
> I put the old file back and subsequently run any flavor of p4 verify, I can
> only assume that either it's doing something wrong, or that my understanding
> of what it's supposed to do is wrong. Either way, fixing it up would be
> nice. :)
>
> Thanks again!
>
> -- Joe
>
> On 9/29/05, Jeff Jensen <jeffjensen at upstairstechnology.com> wrote:
> >
> > One scenario this will occur in is when the metadata thinks the file (or
> > version(s) of the file) exists but it actually does not. Then, of course "p4
> > verify -v" can't calculate the hash on a file that doesn't exist (on a
> > file/version), and p4 verify reports it has a missing MD5 (from metadata).
> >  Since your note suggests you did some playing with the versioned files,
> > perhaps the above explains that not all is well in the versioned files now.
> >  So perhaps the secret you seek is it needs a file/version to calculate
> > on! :-)
> >
> >  ------------------------------
> > *From:* perforce-user-bounces at perforce.com [mailto:
> > perforce-user-bounces at perforce.com] *On Behalf Of *Joseph Cochran
> > *Sent:* Thursday, September 29, 2005 8:50 PM
> > *To:* perforce-user at perforce.com
> > *Subject:* [p4] Verify -v not -v'ing...
> >
> >  I appreciate the advice so far: we've managed to set perforce up how we
> > want it. One last small issue remains!
> >
> > I'm using the method suggested by Richard Baum's "Commit Trigger
> > Example" to save out old revisions from an archive file and replace it with
> > a stub file. The method instructs me to run "p4 verify -v" on my file
> > revision to update the MD5 hash. However, when I do that, I get MISSING! as
> > a result. Replacing the file makes the MISSING! go away (as one would
> > expect), but -v never seems to actually work. I made the user attempting it
> > "super" protect level, but that still didn't do it.
> >
> > What's the secret to making p4 verify -v actually recalculate the stored
> > MD5 signature?
> >
> > Thanks again for all the help!
> >
> > -- Joe
> >
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://maillist.perforce.com/pipermail/perforce-user/attachments/20051003/25daa5ea/attachment-0006.html>


More information about the perforce-user mailing list