[p4] p4tar/p4untar in cygwin?

Jay Glanville Jay.Glanville at naturalconvergence.com
Wed Oct 26 16:00:08 PDT 2005


I found that it would hang near line 123, in the subroutine/method
PipeIn, either on the "open(PIPE..." or the "print PIPE ..." lines.  I
thus assumed that the cygwin perl interpreter had problems with pipes.

Just my $0.02.  My perl is so bad I wouldn't offer anything more then
$0.02.  ;-)

JDG

> -----Original Message-----
> From: Jeff Grills [mailto:jgrills at drivensnow.org] 
> Sent: Wednesday, October 26, 2005 6:43 PM
> To: Jay Glanville; 'Perforce Users Mailing List'
> Subject: RE: [p4] p4tar/p4untar in cygwin?
> 
> 
> It's not just you.  I haven't ever tried to figure out what 
> the issue is,
> though.  Perhaps I'll have some time to look at it tonight.
> 
> j
> 
> -----Original Message-----
> From: perforce-user-bounces at perforce.com
> [mailto:perforce-user-bounces at perforce.com] On Behalf Of Jay Glanville
> Sent: Wednesday, October 26, 2005 8:29 AM
> To: Perforce Users Mailing List
> Subject: [p4] p4tar/p4untar in cygwin?
> 
> 
> Hello P4'ers
> 
> Has anyone had any success with using Jeff's p4untar tool in a cygwin
> environment?  I think that there may be a problem with the 
> perl interpreter
> in cygwin and p4tar's usage of pipes.
> 
> The only way I could get results was if I uninstalled the 
> perl interpreter
> from cygwin and installed a Win32 perl interpreter from ActiveState.
> 
> Has anyone else come across this problem?  (i.e.: or is it just me?)
> 
> JDG
>  
> ---
> Jay Dickon Glanville
> 
> _______________________________________________
> perforce-user mailing list  -  perforce-user at perforce.com
> http://maillist.perforce.com/mailman/listinfo/perforce-user
> 
> 




More information about the perforce-user mailing list