[p4] Help upgrading..

Jeff Grills jgrills at drivensnow.org
Sat Oct 29 17:36:24 PDT 2005


Well, that could certainly be it, but that wasn't what I thought the problem
was.  I would try what you are suggesting.

j

-----Original Message-----
From: Christian Fernandez [mailto:cfernandez at voicesignal.com] 
Sent: Saturday, October 29, 2005 7:05 PM
To: Jeff Grills
Cc: perforce-user at perforce.com
Subject: Re: [p4] Help upgrading..


Hello.. hmm I notes that I am not using -r to tell it were my db files are..
I think it may be that?  mines are on /p4root but when I run p4d -xu it 
creates the db files
under /root (the dir I am running it from)
and my .sh script is:
p4d -p4000 -d -r /p4root -J /var/log/journal

but I am not running it with -r so should I try that?
doing a p4d -xu -r /p4root ?




Jeff Grills wrote:
> I would guess that your p4dstart.sh script invokes a different p4d 
> executable than the one found in your path.
>
> j
>
>
> -----Original Message-----
> From: perforce-user-bounces at perforce.com
> [mailto:perforce-user-bounces at perforce.com] On Behalf Of Christian 
> Fernandez
> Sent: Saturday, October 29, 2005 6:45 PM
> To: perforce-user at perforce.com
> Subject: [p4] Help upgrading..
>
>
> I keep running p4d -xu it says is done then I try to start the server
> and keeps saying I need to upgrade database... below is all the 
> results..  and perforce support is closed today :-(
>
>
> /p4dstart.sh
> Perforce server error:
>        Database is at old upgrade level 7.  Use 'p4d -xu' to upgrade 
> to
> level 10.
> perforce ~ # p4d -xu
> 2001.1: splitting db.integ into db.integed and db.resolve.
> 2001.1: splitting db.have into db.have and db.label.
> 2002.1: splitting pending db.change into db.changex.
> 2002.2: upgrading tempobj filetype in db.rev.
> 2002.2: upgrading tempobj filetype in db.working.
> 2003.1: initialize default depot.
> 2003.2: upgrading db.user.
> 2005.1: building db.revhx (headrev) table.
> 2005.1: upgrading db.locks table.
> 2005.1: building lazy-copy index
> ...upgrades done
> perforce ~ # ./p4dstart.sh
> Perforce server error:
>        Database is at old upgrade level 7.  Use 'p4d -xu' to upgrade to 
> level 10.
> perforce ~ # p4d -xu
> ...upgrades done
> perforce ~ # ./p4dstart.sh
> Perforce server error:
>        Database is at old upgrade level 7.  Use 'p4d -xu' to upgrade to 
> level 10.
> perforce ~ # p4d -xu
> ...upgrades done
>
>   






More information about the perforce-user mailing list