[p4] no 'p4 branches' after conversion using cvs2p4?

Smith, Jeff jsmith at medplus.com
Thu Jul 20 09:04:58 PDT 2006


That would be the tool I wrote which can be found in the perforce public
depot at

//guest/jeffery_g_smith/perforce/utils/cvs2p4/bin/cvs2p4lblfix.py

I believe it require Python 2.4 although it might work under 2.3.

Let me know if you have any questions about its use.
 
Jeff Smith

-----Original Message-----
From: perforce-user-bounces at perforce.com
[mailto:perforce-user-bounces at perforce.com] On Behalf Of Y Giridhar
Appaji Nag
Sent: Thursday, July 20, 2006 8:07 AM
To: perforce-user at perforce.com
Subject: [p4] no 'p4 branches' after conversion using cvs2p4?


Hi p4/cvs2p4 users,

I tried converting a cvs repository with a lot of branches and labels to
p4 using cvs2p4.  The conversion went through fine and the change
history looks good.  I am also able to view the labels in the created
repository using 'p4 labels' but 'p4 branches' doesn't show up any
branches.  This is inspite of the p4 filelog showing the appropriate
"... branch from/into //depot" log messages.

Do I have to manually create the branches using 'p4 branch' and set the
branch view in the branch specification?  Or am I missing something?

Also, where can I find the post-cvs2p4-conversion label conversion tool
that has been refered to in this email thread:
<http://maillist.perforce.com/pipermail/perforce-user/2005-November/thre
ad.html#16887>?

Giridhar

-- 
Y Giridhar Appaji Nag | http://www.appaji.net/
_______________________________________________
perforce-user mailing list  -  perforce-user at perforce.com
http://maillist.perforce.com/mailman/listinfo/perforce-user




More information about the perforce-user mailing list