[p4] Perforce performance halts during large file copy

Jeff Desharnais jdesharnais at maddocsoftware.com
Sun Nov 12 20:33:59 PST 2006


4 processors, and they never seem to be under heavy load.


-----Original Message-----
From: Chuck Karish [mailto:chuck.karish at gmail.com]
Sent: Sat 11/11/2006 6:06 PM
To: Jeff Desharnais
Cc: perforce-user at perforce.com
Subject: Re: [p4] Perforce performance halts during large file copy
 
How many processors does your server system have?

  Chuck

On 11/9/06, Jeff Desharnais <jdesharnais at maddocsoftware.com> wrote:
>
> We are running Perforce 2005.2 on a Windows Server 2003.
>
> We are having problems where the Perforce server grinds to halt when
> someone is copying a large set of files to the machine that runs the
> perforce server... Even though the files are being copied to a different
> drive than Perforce's.
>
> Recent scenario:
>
> User begins copying 18gigs of data to a drive on the server.
>
> Perforce appears to hang up completely and everyone loses access to the
> depots.
>
> We restart the service and it runs okay for a few mintues. Shortly
> after, Perforce becomes very slow and eventually grinds to a halt again.
>
> The file copy is canceled and things are now running fine again.
>
>
> Can anyone explain why this may be happening? I don't see the system
> being hogged by I/O yet Perforce still seems to grind to a halt during
> network I/O activity. This also happened when a user tried using Winrar
> to extract files that live on the server. Same results - Perforce grinds
> to a halt.
>
> Any ideas?
>
> Thanks,
>
> ---------------------
> Jeff Desharnais
> IT Specialist
> Mad Doc Software
> 100 Burtt Rd., Suite 220
> Andover, MA  01810
> (978) 409-6272 Ext. 132
>
> _______________________________________________
> perforce-user mailing list  -  perforce-user at perforce.com
> http://maillist.perforce.com/mailman/listinfo/perforce-user
>


-- 
Chuck Karish   karish at well.com   (415) 317-0182




More information about the perforce-user mailing list