[p4] Ant and p4.change property not getting set

Harsha DN harsha.dn at mphasis.com
Wed Nov 15 07:53:48 PST 2006


Hi,

 

I am running p4:change to obtain a change list number to insert a zip
file to perforce through ant.  There is an error thrown -  Problem
exec'ing P4 command: p4 -<port> -<user> -c<client> change -o error=2.  I
tried running Ant in verbose mode with debug enabled and found a blank
line getting appended to the p4change task while it is executing.  The
path to p4.exe is configured in an environment file. There are no blank
lines in this file.  I tried setting the path in the system environment
variables.  Even with this, the blank line is getting appended while
executing the p4:change.  I appreciate any inputs as to how I can get
rid of this!

 

Cheers,

Harsha

 

 

Ant output...

 

[p4change] Executing 'p4' with arguments:

[p4change] '-p<port>'

[p4change] '-u<user>'

[p4change] '-c<client>'

[p4change] 'change'

[p4change] '-o'

[p4change]

[p4change] The ' characters around the executable and arguments are

[p4change] not part of the command.

 

 




More information about the perforce-user mailing list