[p4] cygwin p4 and local file spec syntax

Wade Scholine Wade.Scholine at citrix.com
Wed Nov 15 12:36:30 PST 2006


I am trying to use the cygwin p4 client.
 
p4 info reports the right stuff: in particular, the client name and
client root are correct. p4 have assures me that the files are present
on the client. p4 -V confirms that I'm using the cygwin version of p4.
 
But I can't get the cygwin p4 to do anything with files using local file
names... it keeps insisting 'file(s) not on client'. Even when I supply
the full (relative to /) path to the file. Even after a p4 sync -f.
 
I tried using a client made with p4win and an altroot set to the cygwin
(/cygdrive/c/...) path to the client. I tried making an entirely new
client using the cygwin p4.
 
I searched the mailing list archives, and saw a lot of old messages
about problems with cygwin, but they seem to all be about problems with
mapping between windows paths and cygwin paths. I don't have problems
like that, I am not trying to use any non-cygwin tools or editors. I am
just trying to set up a *ix-like workspace so I can use a decent shell
and ed to make some mass edits.
 
Does the cygwin p4 client just not work, or not work with NT p4 servers?
Do I just need to set up a linux box if I want to use p4 with unix
filesystem semantics?
 
Wade S
x27859
 



More information about the perforce-user mailing list