[p4] vexing p4v problem on mac os

Jon Gamble jon.gamble at analex.com
Wed Aug 1 20:30:55 PDT 2007


More info:  I'm running the eval version of p4d, the latest binary available as of 8/1.  p4d is running in a launchd configuration (but always up, not brought up to handle requests transiently like some launchd services).

I would steer away from thinking this is a server issue though, all other client software on multiple platforms I've tried work fine for the exact same perforce user/workspace/password combo.

-jon

-----Original Message-----
From: perforce-user-bounces at perforce.com on behalf of Jon Gamble
Sent: Wed 8/1/2007 10:27 PM
To: steve at vance.com; perforce-user at perforce.com
Subject: Re: [p4] vexing p4v problem on mac os
 
> Did the security level on your server change? How about the IP address?
> Pull up a command shell and type 'p4 set'. Get rid of the environment
> setting from your startup files. You can also try deleting your tickets
> folder (~/.p4tickets by default). Do all of this while P4V is shut down.
> Restart P4V and try again. You can also try 'p4 login' from the command
> line and see how that behaves for you.
> 
> Steve

Hi Steve, No, the security level and the IP address have not changed.  p4 login works great - no problems with p4 command line.  As I said, the windows version of p4v works fine.  I'm including the log from the mac version so you can see what I'm talking about.  It starts at the connection dialog, where I enter my password and click OK.  P4V then prompts me again for my password saying:

  A password is required for user 'gamblej' on server '192.168.1.5:1666'
  The password is invalid. [in red]

  Please enter the password

I type it in again and receive a ticket for 24 hours.  Then I try to expand the depot tree and guess what?  The invalid passowrd dialog again.

I can make slow but steady progress by reentering my password over and over ad nauseum but it's clear to me there is something wrong with the p4v mac binary (which I have downloaded and reinstalled twice from the perforce website).  This is a shame too because perforce is a tremendous product and I had high regard for p4v too.  Just so we're clear, I have completely obliterated everything on the mac client multiple times.  this seems to be a p4v bug, that perhaps only affects me.  Perhaps something in my system configuration is tripping p4v up.  It's straight mac os 10.4.10 though.  Nothing sneaky going on.

If this isn't some rare behavior that only affects me, I'm surprised perforce let this build of p4v out the door.

Here's the log from p4v.  It demonstrates what one might expect from reading my description of the app's behavior.

p4 client -o gamblej-mac
p4 login -s
    User gamblej ticket expires in 11 hours 59 minutes.
p4 client -o gamblej-mac
p4 depots
p4 fstat -P -Olh /Users/gamblej/ws/work/*
p4 fstat -P -C -Olh //depot/*
p4 dirs -C //depot/*
    The password is invalid.
p4 login
p4 fstat -P -C -Olh //depot/*
p4 dirs -C //depot/*
    The password is invalid.
p4 login
p4 dirs -C //depot/*
p4 dirs -C //depot/fddr/libfddr/test/*
    The password is invalid.
p4 client -o gamblej-mac
p4 job -o
    The password is invalid.
p4 fstat -P -Olh /Users/gamblej/ws/work/*
    The password is invalid.

-jon


-----Original Message-----
From: steve at vance.com [mailto:steve at vance.com]
Sent: Wed 8/1/2007 8:51 PM
To: Jon Gamble; perforce-user at perforce.com
Subject: RE: [p4] vexing p4v problem on mac os
 
Did the security level on your server change? How about the IP address?
Pull up a command shell and type 'p4 set'. Get rid of the environment
setting from your startup files. You can also try deleting your tickets
folder (~/.p4tickets by default). Do all of this while P4V is shut down.
Restart P4V and try again. You can also try 'p4 login' from the command
line and see how that behaves for you.

Steve

Original Message:
-----------------
From: Jon Gamble jon.gamble at analex.com
Date: 	Wed, 1 Aug 2007 21:11:07 -0400
To: perforce-user at perforce.com
Subject: [p4] vexing p4v problem on mac os



Hi all,

I have been an avid user and proponent of perforce for the past 7 years. 
But I'm currently experiencing some bizarre behavior which I would call a
severe bug - although I can't find any info about it with a google search.

The problem is that on mac os p4v, password protected users simply do not
work for me.  p4v constantly complains about the password with a
never-ending barrage of dialogs.  I know that I'm entering it correctly, I
figured that out after about the 100th time.  Command line p4 with PASSWD
env variable and windows p4v work fine - no problems, smooth sailing.

Any idea what's going on?

CONFIDENTIALITY NOTE:  This transmission is intended solely for the use of
the individual(s) to whom it is addressed and may contain information that
is privileged, confidential, or otherwise exempt from disclosure under
applicable law.  If the reader of this message is not the intended
recipient, or an authorized representative of the intended recipient, you
are hereby notified that any review, retransmission, dissemination,
distribution, copying of or taking of any action in reliance upon this
communication is strictly prohibited.  If you have received this
communication in error, please delete it from your system without copying
or forwarding it, and notify the sender of the error by reply e-mail.
_______________________________________________
perforce-user mailing list  -  perforce-user at perforce.com
http://maillist.perforce.com/mailman/listinfo/perforce-user


--------------------------------------------------------------------
mail2web.com - Enhanced email for the mobile individual based on Microsoft®
Exchange - http://link.mail2web.com/Personal/EnhancedEmail




CONFIDENTIALITY NOTE:  This transmission is intended solely for the use of the individual(s) to whom it is addressed and may contain information that is privileged, confidential, or otherwise exempt from disclosure under applicable law.  If the reader of this message is not the intended recipient, or an authorized representative of the intended recipient, you are hereby notified that any review, retransmission, dissemination, distribution, copying of or taking of any action in reliance upon this communication is strictly prohibited.  If you have received this communication in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply e-mail.
_______________________________________________
perforce-user mailing list  -  perforce-user at perforce.com
http://maillist.perforce.com/mailman/listinfo/perforce-user


CONFIDENTIALITY NOTE:  This transmission is intended solely for the use of the individual(s) to whom it is addressed and may contain information that is privileged, confidential, or otherwise exempt from disclosure under applicable law.  If the reader of this message is not the intended recipient, or an authorized representative of the intended recipient, you are hereby notified that any review, retransmission, dissemination, distribution, copying of or taking of any action in reliance upon this communication is strictly prohibited.  If you have received this communication in error, please delete it from your system without copying or forwarding it, and notify the sender of the error by reply e-mail.



More information about the perforce-user mailing list