[p4] Change spec appears to be badly damaged!

markm at emeter.com markm at emeter.com
Mon Aug 13 10:36:38 PDT 2007


Hi Marc,

I have seen the same exact problem and the only "solution" I have found
is exactly what you suggest; editing the client spec being used. Over
the course of the last 5 months I have seen this problem with five
different users. Each time, I have worked with Perforce support on the
issue, and we/they have still not been able to recreate the problem or
solve it. Even though it makes little sense, it does seem to be
something corrupt in the client spec. But I only say that because
editing the client spec always makes the problem disappear.

I would be interested in knowing your setup, just to see if it is the
same as what I am running here. 

I am running on a linux server (P4D/LINUX26X86/2006.2/113956
(2007/01/09), and the P4V version with the problems is 2006.1/108384

I have been running the P4V 2007.2/128166 client for several weeks now
and have not yet seen this issue.

Thanks,
Mark

-----Original Message-----
Today's Topics:

   1. Change spec appears to be badly damaged! (Marc Chung)
   2. Re: Backup procedure help required - script for Perforce in
      Windows (DOS/VBS)? (Eric L)
   3. Re: Change spec appears to be badly damaged! (steve at vance.com)


----------------------------------------------------------------------

Message: 1
Date: Fri, 10 Aug 2007 12:06:42 -0700
From: "Marc Chung" <mchung at gmail.com>
Subject: [p4] Change spec appears to be badly damaged!
To: perforce-user at perforce.com
Message-ID:
	<7e81190d0708101206x6ec97efkb8cd3b9c141e4059 at mail.gmail.com>
Content-Type: text/plain; charset=ISO-8859-1

Hi,

Sometimes, after I submit a change list with p4win, I'll get the
following message:

"Change spec appears to be badly damaged!"

Flow:
-> Create change list
-> Submit change list
-> Enter text description in dialog (No way to choose files)
-> Hit submit: Error appears.

The problem also occurs in p4v, but manifests itself differently:

Flow:
-> Create change list
-> Submit change list
-> No files under "Choose files to submit"
-> Submit is disabled

Workaround:
- Creating an identical client spec seems to fix the problem.
- In fact, just modifying the client spec (reordering the views, for
example) and resending the specification seems to fix the problem too.

I likely haven't provided enough information to reproduce the problem,
but hopefully this helps someone.

-Marc


------------------------------




More information about the perforce-user mailing list