[p4] My journal file doesn't truncate after a checkpoint

Ryan perforce-user-forum at forums.perforce.com
Sun May 12 23:30:01 PDT 2013


Posted on behalf of forum user 'Ryan'.

Hi,

I'm trying to sort out correctly backing up my Perforce server.

The first thing I did was to move the journal file so that it was on a different
hard drive to the p4 root using the instructions here:   
https://kb.perforce.com/AdminTasks/SuperuserTasks/MovingServer..SameMachine

I'm running Perforce as a service so I did this:
1. Stopped the service
2. Copied the journal file to C:\PerforceJournals\journal
3. Ran: p4 set -S Perforce P4JOURNAL=C:\PerforceJournals\journal
4. Restarted the service.

The journal seems to update just fine in this new location.

I then created a checkpoint like this:

.\p4d.exe -r D:\Perforce\Server -J
C:\PerforceJournals\journal -jc C:\PerforceCheckpoints\ug

This created these files:
ug.ckp.11
ug.ckp.11.md5
ug.jnl.10

The problem is the journal file here: C:\PerforceJournals\journal is
still the same size. It never gets smaller.

The only thing I seem to be doing differently to most websites I've found
while trying to solve this, is that I'm running Perforce as a service
instead of running p4d.exe. Does Perforce running as a service conflict with
using p4d.exe to create checkpoints?

I also tried creating the checkpoint using p4 admin checkpoint, but got the same
results.

Thanks,

Ryan.



--
Please click here to see the post in its original format:
  http://forums.perforce.com/index.php?/topic/2536-my-journal-file-doesnt-truncate-after-a-checkpoint



More information about the perforce-user mailing list