[p4] Suspected freeze at Visual Studio 2013 plugin

P4Shimada perforce-user-forum at forums.perforce.com
Tue May 5 14:55:01 PDT 2015


Posted on behalf of forum user 'P4Shimada'.

Hello,

Sorry to hear you are experiencing freezing with your P4VS plug-in. To help
trouble-shoot this issue, please see the following:

A]  Which version of P4VS are you using?  In Visual Studio,
go to:  Tools -> Extension Manager . 

B] What version of Windows are you using? 

C] Have you tried the new  'Lazy Load' option?

This should alleviate the issue of many fstats on your project files. It was
introduced in the version 2015.1 of P4VS. This feature is turned on/off via the
menu Tools -> Options -> Source Control -> Perforce General.

The "Lazy Load" feature was designed to cut down load time and general
performance on large projects and/or slow connections.  The doc also
describes the feature here:

    
http://ftp.perforce.com/perforce/r15.1/doc/manuals/p4vs/intro.preferences.html#intro.preferences.general.files

The P4VS release notes mention it here under New functionality in 2015.1,
1020819 (Bug 77607) *:

     http://www.perforce.com/perforce/doc.current/user/p4vsnotes.txt

D] Modify your refresh settings

  
-  From P4V, go to Edit --> Preferences --> Server Data and change Check
  server for updates every from 5 to  1440  minutes (i.e., 24
  hours).  that's the largest value P4V will accept.
  
-  From Visual Studio, go to Tools --> Options --> Tools Source Control
  --> Perforce - Data retrieval, change Check server for updates every from 5
  to  1440  minutes.


Please let us know if either option C or D helps resolve your issue.



--
Please click here to see the post in its original format:
  http://forums.perforce.com/index.php?/topic/4057-suspected-freeze-at-visual-studio-2013-plugin



More information about the perforce-user mailing list