[p4] Changed P4EDITOR, now can't save any changes

P4Sam perforce-user-forum at forums.perforce.com
Wed Aug 24 19:30:01 PDT 2016


Posted on behalf of forum user 'P4Sam'.

There are a few different things going on here, it sounds like.




Quote
>   For example if I run "p4 user" and try to save the edit, a pop up will show up asking me to save t(some id).tmp.txt.  I can save the tmp file but the changes will not be saved.    
It sounds like we're asking your editor to edit (eg)
"t123456789.tmp" and what it's doing is appending a
".txt" suffix to that name, which of course is not the same name we
passed it and makes us unable to see the saved changes.  Is there any
way to configure it to not do that?  

Failing that, you could maybe wrap the editor in a little batch script that runs
the editor and then renames its output back to the correct
name.  Which editor is this?




Quote
>   I have tried changing the default editor back, and to other settings. The results were the same.     Meaning that other text editors you tried had the same behavior of appending ".txt"?  Or that after changing P4EDITOR the same (incorrect) editor kept coming up?




Quote
>   I tried unsetting P4EDITOR, and it brought up a vi window reporting the editor to be read-only.    Meaning that at the time you ran "p4 set" a vi window popped up?  Or after unsetting P4EDITOR the next command you ran that wanted to edit a spec brought up a vi window?  What was the exact command you ran that resulted in a vi window coming up?



Quote
>   I'm running 2015.2/1252060 on a Windows 10 machine, and am wondering if maybe there's some registry settings that need to be flipped.    
There shouldn't be anything you might need to change in the registry that
you can't do via the "p4 set" command.  Could you run:

p4 set P4EDITOR

and paste the output here?  That will tell us what value is set for
P4EDITOR, if any, and how it is set.



--
Please click here to see the post in its original format:
  http://forums.perforce.com/index.php?/topic/4914-changed-p4editor-now-cant-save-any-changes


More information about the perforce-user mailing list