[p4] p4v.app and macOS 10.12 launch issues

AhiyaHiya perforce-user-forum at forums.perforce.com
Thu Mar 16 09:05:01 PDT 2017


Posted on behalf of forum user 'AhiyaHiya'.

I started using the latest P4V (VERSION P4V/MACOSX1011X86_64/2017.1/1491634) and
for the first day, it worked fine. However, the next day that I went to use it,
I get the following error:

Connect to server failed; check $P4PORT.
Execution Failed:
/private/var/folders/95/3dtgzj5d12qd1g2_bt50c_k80000gn/T/AppTranslocation/58C7D896-B0C8-413F-AD0E-51488F393C7B/d/p4v.app/Contents/Resources/DVCS/p4d
-r "/Users/jaimerios/Development/Perforce/Atlas_local/.p4root" -i: No
such file or directory


Looking online, I found that the issue may be related to GateKeeper (a macOS
feature) and used AppCleaner.app to remove the P4V app and it's related
files. 

When I went to relaunch the app, it worked fine and I thought I had resolved the
issue.

However, the problem occurred again this morning. When I check the path, listed
above in AppTranslocation, the folder is empty.

So, how does one go about fixing this issue?



--
Please click here to see the post in its original format:
  http://forums.perforce.com/index.php?/topic/5245-p4vapp-and-macos-1012-launch-issues


More information about the perforce-user mailing list